Opened 3 years ago

Closed 8 months ago

#10125 closed defect (duplicate)

SCI: LSL7 PL: Polish typed text not recognized (only english), game freeze

Reported by: szczuru Owned by: bluegr
Priority: normal Component: Engine: SCI
Keywords: sci32 Cc:
Game: Leisure Suit Larry 7

Description

This is another issue that i've found in official Polish version of LSL7
(Previous issues: #10066 )

So in polish version all commands typed from keyboard are in polish language but in ScummVM all commands must be typed in english. And "top bar" (where are options like save/load) is also in english ("outside" of ScummVM this bar is in polish).

Attachments (1)

Przechwytywanie.JPG (85.1 KB ) - added by szczuru 3 years ago.
Game freeze in this scene

Download all attachments as: .zip

Change History (8)

by szczuru, 3 years ago

Attachment: Przechwytywanie.JPG added

Game freeze in this scene

comment:1 by szczuru, 3 years ago

Priority: normalhigh
Summary: SCI: LSL7 PL: Polish typed text not recognized (only english)SCI: LSL7 PL: Polish typed text not recognized (only english), game freeze

Also game freeze right after "balcony" scene :(

comment:2 by szczuru, 3 years ago

Strage...
Issue with english text isn't present in PS3 version (using latest daily build and same game files from Windows verion). But game still hangs on very same moment.

comment:3 by csnover, 3 years ago

Keywords: sci32 added

comment:4 by csnover, 3 years ago

Cc: cnsover removed

comment:5 by csnover, 3 years ago

Priority: highnormal

comment:6 by zdzisekM, 2 years ago

Hello, I've created account especially to report I've solved this issue, I'm not sure it's working 100% through the game, but for sure it fix free after 'balcony scene', layout (GUI) is in polish, subtitles are polish and you can type polish words for 'other actions'. ScummVM will throw one warning 'Failed to find volume for map.2' and can't recognize files RESOURCE.AUD (obvious), RESSCI.000, RESMAP.000.

Solution:

  1. you need working english 1.01 version
  2. not sure if it's needed but I've renamed all files in polish version folder to upper case (all files in english version are upper case)
  3. copy and replace files RESOURCE.AUD and RESOURCE.SFX (possible it's identical to english one) from polish to english
  4. copy and replace files from DATA to PATCHES (english 1.01. version contains such folder)

Hope this will help to fix it.

comment:7 by bluegr, 8 months ago

Owner: set to bluegr
Resolution: duplicate
Status: newclosed

So we got two issues here:

  • the game hanging seems to be caused by corrupted game files
  • the Polish characters issue has been reported again in bug #11274, and a fix has been added, which is connected with that bug report

Thus I'm closing this in favor of #11274

Note: See TracTickets for help on using tickets.