#10123 closed enhancement (wontfix)

TITANIC: External lift level indicator is inconsistent

Reported by: dafioram Owned by: dreammaster
Priority: normal Component: Engine: Titanic
Keywords: Cc:
Game: Starship Titanic

Description

ScummVM and the original engine are doing this the same way.

Outside of the lifts are horizontal lines that move up and down that depend on the level that the lift is at. There is two since each lift shows its level and the one next to it so lift1/lift2 are paired and lift3/lift4 are paired.

The problem is that sometimes for a particular lift, its position is shown on the left and sometimes it is shown on the right. When looking at a particular lift which vertical strip contains that lifts level depends on which lift you are looking at and which floor you are on.

Now I will list on which floors, whether the left or right vertical strip indicates that lifts floor.

Lift 1 Lift 2
Top L L
1st Class R R
2nd Class R L
SGT Class R N/A

So for example if you are on a 2nd class level and you are looking at Lift1 then its floor level will be the height of the horizontal line in the right vertical strip (the left vertical strip will contain lift2's level).

All of the details above are exactly the same with lift1 switched for lift3 and lift2 switched for lift4.

Furthermore, there are some "wings" on the outside that don't point the same ways on each floor.

Attachments (1)

Second Class Floor Lift2.png (306.0 KB) - added by dafioram 21 months ago.

Download all attachments as: .zip

Change History (5)

Changed 21 months ago by dafioram

comment:1 Changed 21 months ago by dafioram

The attached image shows the wings, and left and right vertical strips. I am looking at lift2 on a 2nd class level (floor 20) so that you can see that lift2 is current at the top and lift1 is currently at floor 20. This is the 4rth row, 3nd column of the table above (so the current lifts level that I am looking at is on the Left).

comment:2 Changed 21 months ago by dafioram

It maybe more useful to make a note of this issue/fact somewhere (like http://wiki.scummvm.org/index.php/Starship_Titanic or http://wiki.scummvm.org/index.php/Titanic) then to actually make this behavior more sensible for the game.

comment:3 Changed 21 months ago by dafioram

Maybe it would make sense to add a bugs page for this game and this could list the bugs known about in the original game, and whether or not they are fixed in scummvm. This would be different from the todo list since todo implies it should be done while listing a known bug that is not fixed in scummvm doesn't necessarily need to be done.

I think this bug would be a good case for a bug that should be known, but doesn't need to be fixed.

If this bug page was made it wouldn't be required to go back in the bug tracker and add all previous items that have been fixed, just to update it moving forward.

A candidate for a bug that was in the original game, but has been fixed in scummvm is that the fuse being in or out for the chicken gave you hot chickens in both cases in the original ver c, but in scummvm it is only when the fuse is in.

comment:4 Changed 20 months ago by dreammaster

Owner: set to dreammaster
Resolution: wontfix
Status: newclosed

A bit of experimentation, this seems to be consistent. Weird but consistent. Lifts 1 & 3 can go all the way to floor 39 (the bottom of the well), whilst lift 2 and 4 only go to floor 27 (2nd class). When looking at the indicators on the lifts, you'll see one is short and one is long, representing the short & longer lifts accordingly. It's a bit weird that in some cases the short/long areas are flipped horizontally, but I guess that came down to an aesthetic design implementation when creating the game.

Particularly since this is the way the original intended, I don't think we need to change anything, and I don't think it really counts as a bug either.

Note: See TracTickets for help on using tickets.