Opened 3 years ago

Closed 3 years ago

#10108 closed defect (fixed)

MOHAWK: Myst: Mechanical Age Fortress rotation glitch

Reported by: eriktorbjorn Owned by: bgK
Priority: normal Component: Engine: Mohawk
Keywords: Cc:
Game: Myst

Description

After pushing the red button at the top of the elevator in the rotating fortress, the animation of the turning gears sometimes continue playing outside the elevator.

I'm not sure exactly what triggers this. First I thought it might be pressing the button before the animation has finished, but it seems to happen anyway sometimes.

I have only tried this with the Masterpiece version of Myst.

Attachments (1)

scummvm00000.png (93.6 KB ) - added by eriktorbjorn 3 years ago.
Screenshot of gears animation showing in the wrong room

Download all attachments as: .zip

Change History (3)

by eriktorbjorn, 3 years ago

Attachment: scummvm00000.png added

Screenshot of gears animation showing in the wrong room

comment:1 by dafioram, 3 years ago

Summary: MOHAWK: Fortress rotation glitchMOHAWK: Myst: Mechanical Age Fortress rotation glitch

Thanks for your report.

This can be reproduced by raising the left lever up and then also raising the right lever to get the machine spinning a bit and then clicking the red button while its still spinning. It is important to not pull down the left lever as that will stop the movement and prevent the bug.

I am able to reproduce this on:
Myst ME on scummvm
Myst ME on original engine
Myst on scummvm

I don't have the regular myst installed so I couldn't test the original engine, but I expect it also has this bug in the original engine.

comment:2 by bgK, 3 years ago

Owner: set to bgK
Resolution: fixed
Status: newclosed

Good catch. Fixed in commit cf9646e.

Note: See TracTickets for help on using tickets.