Opened 21 months ago

Closed 21 months ago

Last modified 21 months ago

#10067 closed defect (fixed)

TITANIC: Lift1 always on floor 1 when taking lift2 up

Reported by: dafioram Owned by: dreammaster
Priority: normal Component: Engine: Titanic
Keywords: Cc:
Game: Starship Titanic

Description

1.10.0git-4218-ga503af4

Start at the top of the well.

  1. Take lift 1 up to floor 5
  2. From that floor take lift 2 up to floor 10
  3. From that floor get into lift 1

you are now on floor 1.

If you look at the floor number it says floor 01, if you leave the elevator you are on floor 1. If you re-enter the elevator from floor 1 it will come from 10 to 1, but if you get in and try to go to 10 it will say we are already there, but if you leave again you will be on floor 1.

Elevator 2 works as intended. This behavior is not in the original. The other lifts worked as intended.

If you take lift 1 to any level other than 10 in this instance it will work as intended.

So the issue is that lift1 is changing its exiting floor and displayed floor number to be floor 1 when it gets called from a different floor, but the liftbot is getting correctly updated to what floor it is on.

Attachments (1)

titanic-win-1.020 (106.6 KB) - added by dafioram 21 months ago.
top of the well with lift2 on floor 5 and lift1 thinking its on floor 5

Download all attachments as: .zip

Change History (4)

Changed 21 months ago by dafioram

Attachment: titanic-win-1.020 added

top of the well with lift2 on floor 5 and lift1 thinking its on floor 5

comment:1 Changed 21 months ago by dafioram

In my saved game all the liftbots think they are on floor 5.

Last edited 21 months ago by dafioram (previous) (diff)

comment:2 Changed 21 months ago by dreammaster

Owner: set to dreammaster
Resolution: fixed
Status: newclosed

I have to say, I'm damn impressed with your ability to have identified obscure bugs like this. In this case, there was an accidentally added line setting the game to floor 1, but only when the lift 1 was entered from a first class floor.

comment:3 Changed 21 months ago by dafioram

I questioned my sanity when I first encountered this.

Note: See TracTickets for help on using tickets.