#10063 closed defect (fixed)

MOHAWK: Riven: Graphics glitch when panning left on Prison Island.

Reported by: macca8 Owned by: bgK
Priority: normal Component: Engine: Mohawk
Keywords: Cc:
Game: Riven

Description

While walking along the path towards the stairs leading up to Catherine's prison, stop one step before reaching the stairs and turn right to face the island.

When you turn back (pan left), the water effects are distorted during the transition, and the right edge of the scene above the water effects line wraps around to the left edge of the screen (see attached screenshot).

Last known without glitch: 1.10.0git3775-geb73062 (11 July 2017)
First detected (oldest available): 1.10.0git4012-g7b61e71 (20 July 2017).

This period includes these fixes:
#9928 (11 July), #9958 (14 July), #9947 & #9960 (15 July), #9969 & #9970 (19 July), #9972 (20 July).

Current Daily Build: 1.10.0git4290-gf9c370d (5 August 2017)
Game Version: English, 5-CD (contains v1.02 patch files)
Platform: Intel Mac (OS X 10.6.8)

Attachments (4)

Prison Island pan glitch.png (281.5 KB) - added by macca8 23 months ago.
Cursor indicates water effects line.
riven-007.rvn (25.5 KB) - added by macca8 23 months ago.
Move forward one step, turn right, then turn left.
scummvm00008.png (312.9 KB) - added by dafioram 23 months ago.
DVD glitch with wrapped screen graphic and bottom half blurred. The blurring doesn't stay.
riven-053.rvn (24.9 KB) - added by dafioram 23 months ago.
DVD save prison island

Download all attachments as: .zip

Change History (7)

Changed 23 months ago by macca8

Cursor indicates water effects line.

Changed 23 months ago by macca8

Attachment: riven-007.rvn added

Move forward one step, turn right, then turn left.

comment:1 Changed 23 months ago by dafioram

DVD version 1.2:
I also get this, but I can get it to do the left wrap around issue with Water Effects Disabled and transitions set to Fastest. Can you confirm this is your setup as well macca8?

If I turn on water effects I get another bug where the bottom half of the screen looks like blinds are being closed: https://streamable.com/0ajsb

You don't have to spin left, but I found that made it easier to reproduce.

Changed 23 months ago by dafioram

Attachment: scummvm00008.png added

DVD glitch with wrapped screen graphic and bottom half blurred. The blurring doesn't stay.

Changed 23 months ago by dafioram

Attachment: riven-053.rvn added

DVD save prison island

comment:2 Changed 23 months ago by dafioram

Neither of these two graphics glitches that I am observing occur in the original dvd version of the game.

comment:3 Changed 23 months ago by bgK

Owner: set to bgK
Resolution: fixed
Status: newclosed

Thanks this is now fixed (c6e6d0b3d)

Note: See TracTickets for help on using tickets.