#10060 closed defect (fixed)

TITANIC: Movement with arrow keys unexpected behavior

Reported by: dafioram Owned by: dreammaster
Priority: normal Component: Engine: Titanic
Keywords: Cc:
Game: Starship Titanic

Description

Between creator room and settings room facing the water:
can't turn right with right arrow key. Same for facing opposite side (has the torches lite).

In embarkartion lobby facing top of well door, cant turn right with right arrow key

Outside Parrot room entrance, cannot enter using up-key.

Facing bomb room straight on, cannot enter using up-key (if you are facing sideways you can). Same with fuse room.

After credits, but before getting SGT id you can go into top of well using up arrow key.

I can also enter the creator and cell settings room pre-SGT. I can only enter the creator room with SGT access.

I can also get into the bridge with just SGT access.

Attachments (1)

Bridge.png (200.0 KB) - added by dafioram 23 months ago.
The pet view is kept as if you were navigating if you arrow key out

Download all attachments as: .zip

Change History (5)

comment:1 Changed 23 months ago by dafioram

Summary: TITANIC: Up arrow key unexpected behaviorTITANIC: Movement with arrow keys unexpected behavior

Changed 23 months ago by dafioram

Attachment: Bridge.png added

The pet view is kept as if you were navigating if you arrow key out

comment:2 Changed 23 months ago by dafioram

In the bridge if you enter into the skyscape or starmap and hit the left or right arrow key you now exit the navigation and look left of the bridge and right of the bridge respectively. It should probably not let you do that, especially since it keeps the bottom pet view the same as if you where still doing the navigation. Up and down arrow do nothing in the sky/starmap.

comment:3 Changed 23 months ago by dafioram

With the numpad on trying to label a saved game using the in-game save if you hit one of the directional numbers it will cause you to move.

comment:4 Changed 23 months ago by dreammaster

Owner: set to dreammaster
Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.