#10052 closed defect (invalid)

Riven Cart Glitch

Reported by: JCaesar13 Owned by: bgK
Priority: normal Component: Engine: Mohawk
Keywords: Riven, Cart, RMAP code 000310d9 Cc:
Game: Riven

Description

(Excuse any mistakes)
scummvm 1.10.0.0 (file version) 1.10.0git (product version) [Windows 32-bit Daily Build August 4th 09:43

Game works fine until the end of the cart video. The status window says: "Could not match RMAP code 000310d9!" If the debugger is closed, the game simply closes.

English

DVD-ROM v1.2 for Windows 98 / XP (downloaded from Steam)

Windows 7 Professional 64-bit

(Game saved just before cart sequence--just pull lever)

Attachments (2)

riven-003.rvn (19.4 KB) - added by JCaesar13 21 months ago.
riven-004.rvn (23.3 KB) - added by dafioram 21 months ago.
Forest Island Start

Download all attachments as: .zip

Change History (20)

comment:1 Changed 21 months ago by JCaesar13

Version 1.10.0git4218-ga503af4 (Aug 4 2017 04:11:52)

Changed 21 months ago by JCaesar13

Attachment: riven-003.rvn added

comment:2 Changed 21 months ago by dafioram

This save worked for me on the same build for mingw64 and mingw32.

Does your steam version have all the same files as listed here: http://wiki.scummvm.org/index.php/Datafiles#Riven:_The_Sequel_to_Myst

comment:3 Changed 21 months ago by JCaesar13

Yes, and some extra. The riven.exe, along with a couple dozen other items, is outside of the "Data" file where all the other files on that list are located.

Should I try this on MinGW? How difficult is it for a layman to navigate it?

comment:4 Changed 21 months ago by dafioram

I was just referring to the windows build of scummvm which uses mingw, you are using the same build as me.

Could you make a folder, say riven, that has only the riven files listed in the wiki and add that folder to scummvm via add game and see if you get the same crash?

comment:5 Changed 21 months ago by JCaesar13

No luck. The old save games still showed up so I used the cart save and it crashed with the same error.

Thanks for your help btw I appreciate it.

Changed 21 months ago by dafioram

Attachment: riven-004.rvn added

Forest Island Start

comment:6 Changed 21 months ago by dafioram

Here is a save right after the cart has gone from the first island to the forest island. If you are just getting stuck on the cart this may work. If you're files are missing lots of content then this save may also crash.

You may want to explore the other direction that you can from the start if you haven't already until someone that has worked on the code can help you better.

comment:7 Changed 21 months ago by JCaesar13

New error code: "cannot match RMAP code 00028a18!" This is both with the simple set of data files and when I moved them all back to the original folders with the others.

Lol didn't know there was another way yet--I'll explore the original island some more, see if the new cart clip glitches or not.

comment:8 Changed 21 months ago by bgK

Sounds like ScummVM cannot find some of your datafiles. Please make sure you have "j_Data1.MHK", "j_Data2.MHK" and "j_Sounds.MHK" in your game folder. Also make sure they are actually in that folder, and not in the Windows VirtualStore.

If you have those files please post full md5 checksums of all your Riven files here.

comment:9 Changed 21 months ago by JCaesar13

bb_cvid.qtc: 1673952D82713BF253C76E160B99288B

bb_dci.qtc: 99E845063962D160B3095FC33117B61D

BB_MC32.qt: 10C43D478AEEAD3F6FF1B1315557ED50

CMGR32.DLL: C680CBD43C6799362E266AEAAEA986C5

Cyan.ico: 8E42CFF894140A0BE109360767B5E89A

DHI032.QTC: 1A183961ADC54B4BB3B154AB615687D8

Menus: D41D8CD98F00B204E9800998ECF8427E

Menus.dll: DBC90F43C0C035558DEAEBB98D055DB5

mowhawk.ppc: DF87C9716086EB11004F2D49D77ECD74

Mowhawk.w32: A7273CBEF56DB30975D93B81EEB146F4

mowhawk32.mmx: ECEE410234AF65A429743A548A9A5DA5

movie.txt: 8813F2413603E03399D5667FA96D1C04

QTIM32.DLL: FF095A2434540D101BA2901891D3A5A7

ReadMe Mac: 490C4D760678884BA571C07594F11FF9

Readme.txt: E906123203A929E76338C4FC4FF39A93

Riven: C217046DA06B81FDFB2A36E58780292B

riven.cfg: B70728D3D47A7106755B7F744CA423DF

Riven.exe: DEB6EEA319FC87A4544CACD478F241B6

Riven.ini: AD52B644CFEBD196B113037B4458A70B

riven.usr: 145D539B217BFFAB995AD97A7822CDCF

UBI1.exe: 7D534E53333EFC5BF38CD5293274382F


And then inside the folder "Data"

a_Data.MHK: AD82A3BC2D6A7C2B2AC4DCF7AB95B467

a_Sounds.MHK: 9658363D21012C757ED8EF5412C4F363

b_Data.MHK: 8E7C1091348FE726543C294339379A26

b_data1.MHK: FA08D302E0DD0C124203C0B95CC2223F

b_Sounds.MHK: 758BD07BF60AE2EF344F82EBCF5096AB

b2_data.MHK: E386ACE2719CFE36CC94B7E79C829694

Extras.MHK: 5108D5F01BFDA62E41CC9A6516B7C6AF

g_Data.MHK: 22129FCF4EABBEB567BB2F4B13D54CCF

g_Sounds.MHK: 91A0613B6687315BE0B2F4890F9969FE

j_Data1.MHK: 37226292CDBE478132903ACD711E4D1E

j_Data2.MHK: F8D83DBFFB64CD6AD77BD11444EA72A5

j_data3.MHK: 173C3B218B9603AB42C0F27546D37B22

j_Sounds.MHK: 688F6C309AF690B1AF7116898D9A6D72

o_Data.MHK: 0D93676AA246A9640F91ADCC2ABC29EC

o_Sounds.MHK: 937EA7C694AC011FFAE5318225ACAFE1

p_Data.MHK: F8C8E7D5363CE9BF08F2275438AEA9F4

p_Sounds.MHK: E323B7152B77C6F1A7D0778153593302

r_Data.MHK: 1DC2A0CB62B54D08CE73BC0926E49640

r_Sounds.MHK: 539203E7D98B3648CDACB0DC08EAAF10

t_Data.MHK: 9C4201DC16C7878BD47C571AF79E35F3

t_Data1.MHK: E6F2BB5697BA96C1DF8C8A92C18EA680

t_Data2.MHK: 93CDC66D782C624B756911A8C841DE72

t_Sounds.MHK: 0D1E41E7BE29004637AADF76474AE477

comment:10 Changed 21 months ago by JCaesar13

Hope that's what you need.

comment:11 Changed 21 months ago by bgK

Owner: set to bgK
Resolution: invalid
Status: newpending

You seem to have a mix of CD and DVD version datafiles. Perhaps you had the CD version in that folder and overwrote it with the DVD version?
These files are from the CD version, are not needed in the DVD, and are bound to cause problems:
b_data1.MHK: FA08D302E0DD0C124203C0B95CC2223F
j_data3.MHK: 173C3B218B9603AB42C0F27546D37B22
t_Data.MHK: 9C4201DC16C7878BD47C571AF79E35F3
Delete them, or move them outside of the game folder so that ScummVM can't read them.

If the files are like that after the download from Steam, please tell me so. In that case I would need to add a special case to ignore the unwanted ones.

comment:12 Changed 21 months ago by bgK

Resolution: invalid
Status: pendingnew

Mpff, looks like the files are like this on Steam: https://steamdb.info/depot/63611/

I'll add some code to ignore the extra files.

comment:13 Changed 21 months ago by bgK

Resolution: fixed
Status: newpending

Thanks for your report. The engine has been changed to load only the data files required for the detected version of Riven (Commit 3007bbe). Can you please check with the next daily build that you can transport to jungle island?

comment:14 Changed 21 months ago by JCaesar13

I got the latest development build for W32bit (Aug 6th 04:08:54) and W64bit (Aug 6th 05:39:08) from here http://buildbot.scummvm.org/builds.html. Same error code, either with the three dat files inside the folder or without.

Glad we've done something useful, though.

comment:15 Changed 21 months ago by JCaesar13

I hadn't thought there was a difference, but I just also tried the Win32 ScummVM Daily Snapshot from here http://scummvm.org/downloads/#daily. The site says the last update was 12:34 today, but curiously the program itself says it was 22:31:19 later tonight. Just a mistake I'm assuming.

comment:16 Changed 21 months ago by bgK

The daily build from buildbot does not have the changes yet. The "daily snapshot" from the website does.

Some of your md5sums match my DVD version, some others don't. Did you make sure your files are correct by using the "check files integrity" button in Steam?

comment:17 Changed 21 months ago by JCaesar13

It works. That should've been the first thing I did--it now works even without Scummvm. Thanks for the help; let me know if you need anything else.

comment:18 Changed 21 months ago by bgK

Resolution: fixedinvalid
Status: pendingclosed

Ok, good thing it works for you in the end.

Note: See TracTickets for help on using tickets.