Opened 2 years ago

Closed 2 years ago

Last modified 11 months ago

#10048 closed defect (fixed)

SCUMMVM: opengl window mode bug, no resize

Reported by: legluondunet Owned by: csnover
Priority: normal Component: Graphics
Keywords: Cc:
Game:

Description

Hello,

with the last ScummVM git version, when I want to maximise the window (opengl mode), the video or the graphic game does not resize, see this screenshot:

http://www.hostingpics.net/viewer.php?id=123124Capturedcrande20170803015714.png

http://www.hostingpics.net/viewer.php?id=650113Capturedcrande20170803130322.png

http://hpics.li/620335e

If I minimise then maximize the ScummVM window, the game screen resized correctly, but the bug comes again at the next video/screen.

Thank you for your help

config:
Ubuntu 17.04 Zesty Zapus 64 bits - NVIDIA GeForce GTX 770 - official Ubuntu Nvidia drivers 375.66 - 1920x1080 - Processor Intel i5-3570 3,4 Ghz - 8 Go RAM

ScummVM git version from 2 august 2017

Change History (9)

comment:1 by dafioram, 2 years ago

Is this specific to a particular game or does it happen for other games you have tested with scummvm?

comment:2 by csnover, 2 years ago

This is because the engine is performing pixel format switches for video playback but the backend isn’t dealing with this correctly at the moment. This same problem should happen in any engine that tries to change the pixel format or dimensions of the hardware surface (so e.g. if you run DreamWeb DOS CD fullscreen this should happen too when the game switches modes at the beginning after the text opening).

comment:3 by legluondunet, 2 years ago

I can reproduce the bug with differents games:

Shivers
http://www.hostingpics.net/viewer.php?id=307175Capturedcrande20170803131138.png

The beast within
http://hpics.li/2d90bbc

Phantasmagoria
http://hpics.li/dbab1fd

Beneath a steel sky
http://hpics.li/99180fb

even with ScummVM GUI
http://hpics.li/5be5d5e

comment:4 by legluondunet, 2 years ago

Summary: SCUMMVM: opengl windo mode bug, no resizeSCUMMVM: opengl window mode bug, no resize

comment:5 by dafioram, 2 years ago

This doesn't happen to me on win7-64 (mingw64) is this issue restricted to linux?

comment:6 by dafioram, 2 years ago

Okay, nevermind I was on a old version (1.10.0git-4209-g8864cfc) on the latest (1.10.0git-4215-gbbc781f) this bug is present in windows.

comment:7 by legluondunet, 2 years ago

I can not reproduce this bug with the today's ScummVM git version.

comment:8 by csnover, 2 years ago

Owner: set to csnover
Resolution: fixed
Status: newclosed

Since there have been changes and improvements to the graphics manager code around this area, and the OP is no longer able to reproduce this, I will assume this issue is fixed now thanks to those updates.

comment:9 by digitall, 11 months ago

Component: --Unset--Graphics
Note: See TracTickets for help on using tickets.