Opened 20 months ago

Last modified 15 months ago

#10044 new defect

MOHAWK: Riven: Excessive delay before cursor appears after movie ends.

Reported by: macca8 Owned by:
Priority: low Component: Engine: Mohawk
Keywords: Cc:
Game: Riven

Description

After arriving at Jungle Island in the wood trolley, and it comes to rest, there's an excessive delay before the cursor appears, during which no sound or action occurs.

Following a series of commits in April 2015 by clone2727 (who maintained Riven & Myst at that time), the length of this delay doubled from 4 seconds to the current 8 seconds.

None of these commits are Riven-specific, but do relate to Quicktime, Mohawk and Myst, and contain evidence that at least some of these changes applied to code shared by Riven at the time (which in turn may have since been renamed and/or relocated by the recent Riven overhaul (PR 966)).

It's also likely that only the CD version of Riven is affected by this issue (see below).

These resources may help:

Current Daily Build: 1.10.0git4166-g993b013 (1 August 2017)
Last known with 4 seconds delay: 1.8.0git2913-gd582c84 (23 March 2015)
Game Version: English, 5-CD (contains v1.02 patch files), md5: 71145fdecbd68a0cfc292c2fbddf8e08
Platform: Intel Mac (OS X 10.6.8, 10.11.6)

Confusing the issue, tests from dafioram (recent Windows daily build, refer #9989 for results) produced significantly shorter delays to mine.

Nevertheless, a clear trend did emerge. Delays for the original CD & DVD, and the DVD version on ScummVM were all closely matched. However, the delay for the CD version on ScummVM doubled the others.

Note that my test is based on previous and current behaviour in ScummVM, not a comparison with the original. Lacking an appropriate Windows daily build (before the above commits were applied) for testing, it's difficult to draw any conclusions from this variation between Mac & Windows builds.

Attachments (1)

riven-002.rvn (15.0 KB) - added by macca8 20 months ago.
Click lever, delay begins when sound stops after reaching Jungle Island.

Download all attachments as: .zip

Change History (7)

Changed 20 months ago by macca8

Attachment: riven-002.rvn added

Click lever, delay begins when sound stops after reaching Jungle Island.

comment:1 Changed 15 months ago by macca8

Owner: set to macca8
Resolution: fixed
Status: newclosed

This issue is resolved in the latest stable release (v 2.0.0), 32-bit & 64-bit Intel Mac versions, with the delay time reduced to the expected 2 seconds.

The current Daily Build (2.1.0git134) is still affected, but is no longer relevant now that the game is included in the stable version.

comment:2 Changed 15 months ago by wjp

Owner: macca8 deleted

Great that it behaves as expected in the release build (maybe due to enabled optimizations), but if it's still broken in 2.1.0git, that means any underlying issues haven't been resolved.

Last edited 15 months ago by wjp (previous) (diff)

comment:3 Changed 15 months ago by wjp

Resolution: fixed
Status: closednew

comment:4 Changed 15 months ago by bgK

Indeed the issue is not fixed.

That QuickTime video has entries in its edit list to repeat some sections. However it does not have key frames. Our QuickTime decoder decodes and skips hundreds of frames to be able to display the repeated sections. Decoding is much faster on release builds due to optimizations being enabled.

The original QuickTime decoder does not show this behavior. Perhaps it simply skips short edits altogether. Which would also fix issue #10135. More investigation is required.

comment:5 Changed 15 months ago by macca8

My mistake! Thanks for setting me straight.

comment:6 Changed 15 months ago by wjp

No worries. Thanks for letting us know it works in the release version. That's very useful.

Note: See TracTickets for help on using tickets.