Opened 2 years ago

Closed 23 months ago

#10025 closed defect (fixed)

TITANIC: in fullscreen mode the desktop wallpaper shines through

Reported by: farmboy0 Owned by: bgK
Priority: normal Component: Ports
Keywords: Cc:
Game:

Description

Normally in fullscreen mode the game window is centered in the middle and the other parts of the screen are black.
Sometimes esp. when movies play the desktop wallpaper is visible and blinking on the right side.

Change History (6)

comment:1 Changed 23 months ago by bgK

Are you using the OpenGL graphics mode?

comment:2 Changed 23 months ago by farmboy0

Yes.

comment:3 Changed 23 months ago by bgK

Component: Engine: TitanicPorts
Owner: set to bgK

There is a possible fix in that branch: https://github.com/bgK/scummvm/tree/opengl-clear.

I'll let it settle for a while and push it.

comment:4 Changed 23 months ago by bgK

Resolution: fixed
Status: newpending

The change is now in master as 8e4697946e4b. Please confirm the bug is fixed for you.

comment:5 Changed 23 months ago by farmboy0

I cant reproduce the problem anymore, seems fixed.

comment:6 Changed 23 months ago by bgK

Status: pendingclosed

Good, thanks!

Note: See TracTickets for help on using tickets.