Opened 18 months ago

Closed 14 months ago

Last modified 3 months ago

#10024 closed defect (fixed)

ANDROID: Black screen hang on start up

Reported by: dafioram Owned by: csnover
Priority: blocker Component: Port: Android
Keywords: has-pull-request Cc:
Game:

Description

If I start up the latest build-bot android build (2c6b2532dd19d0ff268dc1c099f4bf18e86a42da July 30) for android-arm and install it on my Android 4.0 tablet or Android 7.0 phone it installs fine, but every time I start the program it hangs at a black screen.

The release versions of scummvm android work just fine.

Merging PR:898 to master may solve this problem.

Attachments (7)

2017-08-01-08-21-26.txt (656.1 KB) - added by dafioram 18 months ago.
catlog
scummvm-debug-2017-11-23-11-33-07.txt (12.3 KB) - added by spinktvis 14 months ago.
scummvm-pr-2017-11-23-11-34-32.txt (17.0 KB) - added by spinktvis 14 months ago.
scummvm debug Screenshot_20171123-113511.png (66.9 KB) - added by spinktvis 14 months ago.
scummvm pr Screenshot_20171123-113527.png (93.1 KB) - added by spinktvis 14 months ago.
scummvm-2017-11-25-21-52-35.txt (19.9 KB) - added by spinktvis 14 months ago.
Screenshot_20171125-215422.png (46.0 KB) - added by spinktvis 14 months ago.

Download all attachments as: .zip

Change History (28)

comment:1 Changed 18 months ago by dafioram

Changed 18 months ago by dafioram

Attachment: 2017-08-01-08-21-26.txt added

catlog

comment:2 Changed 18 months ago by dafioram

Maybe someone could build a current version with PR898 merged in and I can test that and provide feedback? I don't have a build environment for android set up.

comment:3 Changed 15 months ago by csnover

Priority: highblocker

Raising all identified crasher, hang, and memory violation bugs which I could not fully triage myself to blocker priority for the next release.

comment:4 Changed 15 months ago by csnover

Keywords: has-pull-request added

comment:5 Changed 14 months ago by csnover

Owner: set to csnover

comment:6 Changed 14 months ago by csnover

I can’t reproduce a black screen on startup regardless of how the activities are set up in AndroidManifest.xml. Here are the builds I use, which you may try. One is an essentially vanilla build from master, the other is the same but with PR#898 applied:

https://www.dropbox.com/s/s7us7dc6wc7uvic/ScummVM-debug.apk?dl=0
https://www.dropbox.com/s/dzlbd52am0jly52/ScummVM-debug-PR898.apk?dl=0

Eliminating the second activity doesn’t make a lot of sense to me in terms of getting things working since with its intents should only apply to Android TV devices using the Leanback interface.

Please let me know promptly if either or both of these builds work. Thanks!

Last edited 14 months ago by csnover (previous) (diff)

comment:7 Changed 14 months ago by dafioram

I am out of town and will be returning on Tuesday.

comment:8 Changed 14 months ago by dafioram

On my android phone I cannot install either package. It says that it cannot be parsed.

comment:9 Changed 14 months ago by dafioram

Also the file sizes are both under 1mb while the 1.9.0.1 release is about 15 mb so maybe something is up with that or maybe the debug yoi made doesnt include any engines so that is why they may be so small.

comment:10 Changed 14 months ago by csnover

Yes, these builds include only one engine (SCI) so they are smaller than a full build. They are also armv7a builds, which will not run on extremely old/low-end devices. I don’t know what is required to install an APK that is not signed by a valid key; I had no issues using adb install to sideload these directly onto an Android 4.1 tablet, but I would imagine that Android would refuse to install them if you download them directly onto a normal device without developer mode enabled (or at least without Unknown Sources enabled).

Last edited 14 months ago by csnover (previous) (diff)

Changed 14 months ago by spinktvis

Changed 14 months ago by spinktvis

Changed 14 months ago by spinktvis

Changed 14 months ago by spinktvis

comment:11 Changed 14 months ago by spinktvis

I've attached two logs, one for the debug build, the other for the debug PR build. Screenshots as well. As you can see, the debug build gives black screen. The PR build I can at least see the ScummVM menu.

comment:12 Changed 14 months ago by spinktvis

Forgot to add, I'm running a custom ROM, crdroid 3.8.3, android 7.1.2, on my 1+5. Both builds don't work, and crash. Even if I click OK on the error, ScummVM doesn't respond to my touch.

comment:13 Changed 14 months ago by csnover

I have generated a new build which should fix both issues. Please give it a try and let me know how it goes: https://www.dropbox.com/s/s7us7dc6wc7uvic/ScummVM-debug.apk?dl=0

Please note that this build is signed with a different debug key than the old one, so you will need to explicitly uninstall the old build before trying to install this one.

comment:14 Changed 14 months ago by spinktvis

Confirmed that both issues I described earlier are fixed on my device. Unfortunately I don't have a SCI game installed on my phone to test further with. Thanks so much for the fixes, I'm looking forward to running nighties again on my phone.

comment:15 Changed 14 months ago by csnover

Resolution: fixed
Status: newclosed

Thanks for your report! A patch for this issue has been added in commit 404657d80d9e21c31771bdeec9b58317ec3fd938 and will be available in daily builds 2.0.0git-15 and later.

comment:16 Changed 14 months ago by spinktvis

One "regression" I noticed when playing around with the latest buildbot build, is that MT32 emulation is not baked in. The beta build sev placed on the forum (http://forums.scummvm.org/viewtopic.php?t=14364) does include it and it works perfect, would it be possible to include it for the buildbot builds?

Other than that the build runs fine, been playing Riven.

comment:17 Changed 14 months ago by csnover

Here is a build with SCUMM, SCI, and Mohawk engines built in with the MT-32 emulator enabled. Please let me know how it works:

https://www.dropbox.com/s/du30rkhldjhqkn4/ScummVM-debug.apk?dl=1

Changed 14 months ago by spinktvis

Changed 14 months ago by spinktvis

comment:18 Changed 14 months ago by spinktvis

With the last build it seems I've got the SD card bug, unable to browse the storage. Attached log and screenshot.

comment:19 Changed 14 months ago by csnover

Please open new tickets for new bugs and make sure to provide the information requested at https://bugs.scummvm.org. Thanks!

comment:20 Changed 14 months ago by spinktvis

Created a ticket here: https://bugs.scummvm.org/ticket/10333

comment:21 Changed 3 months ago by digitall

Component: PortsPort: Android
Note: See TracTickets for help on using tickets.