Opened 2 years ago

Closed 23 months ago

#10017 closed defect (fixed)

TITANIC: Floating Chicken

Reported by: dafioram Owned by: dreammaster
Priority: normal Component: Engine: Titanic
Keywords: Cc:
Game: Starship Titanic

Description

Scummvm: 1.10.0git-4120-g720e146
Game: Titanic ver C.
OS: Win7-64

When trying to get the core from the parrot with the chicken. You must:

  1. Get the parrot to reach out of his cage and snap a few times
  2. hang the chicken on the other side
  3. Let go

The chicken will float in thin air, but the bird can't get it and you can't put it back in your inventory. Its harder to reproduce than #10016.

Demo: https://streamable.com/rxamd

Attachments (3)

titanic-win-1.009 (102.2 KB) - added by dafioram 2 years ago.
hot plain chicken ready to go
Untitled.png (241.3 KB) - added by dafioram 2 years ago.
floating chicken
CoreGone.png (234.0 KB) - added by dafioram 2 years ago.
Once you've reproduced this bug you can just take the core from under the parrot and get interesting picture like this one (this can also be done in the original engine).

Download all attachments as: .zip

Change History (6)

Changed 2 years ago by dafioram

Attachment: titanic-win-1.009 added

hot plain chicken ready to go

Changed 2 years ago by dafioram

Attachment: Untitled.png added

floating chicken

comment:1 Changed 2 years ago by dafioram

This behavior is in the original engine.

Changed 2 years ago by dafioram

Attachment: CoreGone.png added

Once you've reproduced this bug you can just take the core from under the parrot and get interesting picture like this one (this can also be done in the original engine).

comment:2 Changed 23 months ago by dreammaster

It seems the original game has quite a few places that you've identified where items end up hanging. I guess that this in part due to the core design - items being used are automatically removed from the inventory already, so unless they're explicitly returned to the inventory when the action doesn't work, they'd just remain present.

comment:3 Changed 23 months ago by dreammaster

Owner: set to dreammaster
Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.