Opened 2 years ago

Closed 5 months ago

#10000 closed defect (fixed)

SCI: LB1: Notebook rendering "INCOMPLETE" wrong

Reported by: sluicebox Owned by: sluicebox
Priority: normal Component: Engine: SCI
Keywords: has-pull-request Cc:
Game: Laura Bow 1: The Colonel's Bequest

Description

The word "INCOMPLETE" is rendered incorrectly in the notebook. ScummVM is placing the last "E" on a new line.

Screenshot attached. Play-through with correct text at 18:35: https://www.youtube.com/watch?v=1XUptEPs1RA

Saved game attached at THE END screen right before notebook, made with dos version and nightly build.

Attachments (2)

incomplete_bug.png (4.7 KB ) - added by sluicebox 2 years ago.
laurabow.030 (23.7 KB ) - added by sluicebox 2 years ago.

Download all attachments as: .zip

Change History (8)

by sluicebox, 2 years ago

Attachment: incomplete_bug.png added

by sluicebox, 2 years ago

Attachment: laurabow.030 added

comment:1 by wjp, 2 years ago

This text is drawn by a kDisplay call, with width set to 50. (Hardcoded in script 786.)

kDisplay: 786, 117, 100, 23, 43, 106, 50, 102, 4, 103, 65535, 105, 4

The text "INCOMPLETE" seems to be 52 pixels wide, even in this youtube play-through. Haven't investigated disasm yet to see what happens in SSCI.

comment:2 by m-kiewitz, 2 years ago

wjp, I know that we are currently not pixel perfect in some situations.
I noticed that while watching a Larry 5 Let's Play using ScummVM and the user look at some game credits windows and those windows weren't placed at the same pos as in SSCI.

But when trying to fix it, I encountered a few more issues. Like in some cases we directly use a Sierra-rect, but we shouldn't because Sierra-rects are inclusive and ours are exclusive.

You can also see this in QfG1 character creation when you compare the output of ScummVM and SSCI. They do not match perfectly.

So maybe this is also caused by that code, idk.

comment:3 by m-kiewitz, 2 years ago

sorry for typos, too late and need some sleep

comment:4 by sluicebox, 5 months ago

Keywords: has-pull-request added
Owner: set to sluicebox

comment:5 by Filippos Karapetis <bluegr@…>, 5 months ago

In ca66a776:

SCI: Implement early GetLongest() behavior, bug #10000

comment:6 by bluegr, 5 months ago

Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.